StreetStangs.net  

Go Back   StreetStangs.net > Technical > EEC Management

Reply
 
Thread Tools Display Modes
Old 10-03-2010, 10:27 AM   #1
Wickd GT
Friends
 
Wickd GT's Avatar
 
Join Date: Dec 2004
Posts: 1,645
Need help with this issue

Well you guys know my Son and I finish his turbo Mustang build up. Car was running fine before we took it to the Dyno. After the Dyno car started to do a bad jerking and misfire. We took it back to the Dyno to recheck everything in the tune, but tune is fine. We drove it and car still does it. This happens at cruise only, when the rpm reaches 1500-2000rpm you can hear the momentary skip and when it goes into overdrive forget it, your kidneys are coming out of you. Car at full throttle will not do it, it runs like a raped ape. So this is what I have replaced to no results:

1.Check all grounds
2.New MSD 8.5 spark plug cables
3.New MSD rotor and Cap
4.New plugs gap at .032" Autolite 3923's
5.New TFI module
6.New Distributor
7.Put new vacuum lines.
8. Tested, without the wastgate, tested with the blow off valve to see if is leaking, but all checked out.
9.Check the Mass air and clean the mass were the diodes are.
10. Check without the chip, just the stock computer.
11. Check the harness at the connection to the injectors harness
12. unhook the MSD box
13. Put old Coil
14. Check the turbo
15. Replace both O2 sensors

All of this did not make any improvements. I have spent a ton of money chasing this crap, then to top it off the AOD took a crap. Mike rebuild it completely, everything check out in the bench, well guess what! The damn thing still does not want to down shift, stall the motor when coming to a halt, hangs in second, makes a terrible squeal sound when manually shifted. Adjusted the cable loose tight middle, I hate that cable. So, this is my last effort, looking at getting a bullet proof built AOD from Silverfox.com or a C4 with a transbreak, and put a set of 3.08 or 3.27 so the motor wont be hanging the tongue in the highway.
Any of you guys that are experience with fuel injection can point me to the right direction, before I loose my mind and put a match to this thing and burn it to the ground, that's how close I am. I need to get this fix before I put a new tranny in here, and this one needs to survive until I can find this problem. If this can't be fixed, I'll buy the car from my Son and I'll part it out to the ground.

Edgar

Last edited by Wickd GT; 10-03-2010 at 12:11 PM.
Wickd GT is offline   Reply With Quote
Old 10-03-2010, 11:09 AM   #2
EHardy1971
Trunk Monkey
 
EHardy1971's Avatar
 
Join Date: Jun 2007
Location: Home
Posts: 5,702
Did you check the TPS for a flat/dead spot?
__________________
Eric
89 LX Coupe-Juiced
01 Lightning-Boost
06 TBSS
EHardy1971 is offline   Reply With Quote
Old 10-03-2010, 12:14 PM   #3
Wickd GT
Friends
 
Wickd GT's Avatar
 
Join Date: Dec 2004
Posts: 1,645
Quote:
Originally Posted by EHardy1971 View Post
Did you check the TPS for a flat/dead spot?
The tuner said the TPS was fine, so I'm going by that. Don't have a clue to check this. Someone told me to do a sel test jumping the self test something with KOEO, Key on engine off. Did I ever said I HATE FUEL INJECTION!!! Damn!!!

Edgar
Wickd GT is offline   Reply With Quote
Old 10-08-2010, 08:58 PM   #4
waypastcrazy
ADDICTED TO SMALL BLOCKS
 
waypastcrazy's Avatar
 
Join Date: Jan 2007
Location: lookout mt
Posts: 1,757
need more info.what boost at 1500 to 2000 if any?now and before the tune.What timing now and before?it dont take much change if the working compression was borderline before then something is different at that rpm than before such as more timing, fuel delivery,octane,engine temp,boost,engine load etc.air intake charge is slower and hotter at lower cruise rpm.have u done all the little things such as using a colder plug with the top electrode barely reaching over the center electrode and the top electrode being rounded off around the corners, as wide a gap as possible with a good ignition system valve coating etc.What is the dish piston how far in the hole what shape what cc head ?whats gasket thickness?bore stroke and rod length?and what are the cams intake and exhaust valve opening and closing timing.with all that going on i would get transmission problem corrected first because it could be causing to much or not enough load on engine causing timing,fuel delivery or boost to not be in sinc.just my .02 cents come on guys lets make this a learning thread lord knows I need to learn some stuff.
Clyde
__________________
http://alabamaopencarry.com/forum/index.php
One of StreetStangs class clowns!
Status:slow as hell!
NORTH EAST ALABAMA STANGS

Last edited by waypastcrazy; 10-08-2010 at 09:00 PM.
waypastcrazy is offline   Reply With Quote
Old 10-08-2010, 10:20 PM   #5
waypastcrazy
ADDICTED TO SMALL BLOCKS
 
waypastcrazy's Avatar
 
Join Date: Jan 2007
Location: lookout mt
Posts: 1,757
Also is the aod modulelated or msnual valve body because I would think in a boosted app u would push boost thru the vac line or atleast not have proper vac under boost?not sure on that maybe someone with more experience will chime in lol
__________________
http://alabamaopencarry.com/forum/index.php
One of StreetStangs class clowns!
Status:slow as hell!
NORTH EAST ALABAMA STANGS
waypastcrazy is offline   Reply With Quote
Old 10-08-2010, 11:56 PM   #6
EHardy1971
Trunk Monkey
 
EHardy1971's Avatar
 
Join Date: Jun 2007
Location: Home
Posts: 5,702
Quote:
Originally Posted by waypastcrazy View Post
Also is the aod modulelated or msnual valve body because I would think in a boosted app u would push boost thru the vac line or atleast not have proper vac under boost?not sure on that maybe someone with more experience will chime in lol
AOD doesn't have a vacuum modulator Clyde. What about the BAP sensor, have you checked that Edgar?
__________________
Eric
89 LX Coupe-Juiced
01 Lightning-Boost
06 TBSS
EHardy1971 is offline   Reply With Quote
Old 10-09-2010, 12:37 AM   #7
waypastcrazy
ADDICTED TO SMALL BLOCKS
 
waypastcrazy's Avatar
 
Join Date: Jan 2007
Location: lookout mt
Posts: 1,757
Eric I have seen several with modulater valves if memory is correct I had a 85 truck aod I traded recently and have a 86 ranger with one now and my 93 mustang aod had a modulator valve and my 92 ford explorer 4x4 has one also lol
__________________
http://alabamaopencarry.com/forum/index.php
One of StreetStangs class clowns!
Status:slow as hell!
NORTH EAST ALABAMA STANGS

Last edited by waypastcrazy; 10-09-2010 at 12:40 AM.
waypastcrazy is offline   Reply With Quote
Old 10-09-2010, 12:50 AM   #8
waypastcrazy
ADDICTED TO SMALL BLOCKS
 
waypastcrazy's Avatar
 
Join Date: Jan 2007
Location: lookout mt
Posts: 1,757
Never mind I am thinking of the a4ld trannies
__________________
http://alabamaopencarry.com/forum/index.php
One of StreetStangs class clowns!
Status:slow as hell!
NORTH EAST ALABAMA STANGS
waypastcrazy is offline   Reply With Quote
Old 10-09-2010, 07:20 AM   #9
SvoBrown
Senior Member
 
SvoBrown's Avatar
 
Join Date: Nov 2005
Location: Graham AL
Posts: 1,461
I had a lifter that exploded and caused something like that. Valve stayed open then stayed shut. Beat the hell out of the cam.

another time had an injector bank start going out on the puter. Caused the same thing.

It sounds like the timing is jumping up and down. You might see something with the light on the dyno at cruise speed.

Can you drive it with the spout out, Timing locked and see if that is it. Go low to be safe.
__________________
''Life's tough... it's even tougher if you're stupid.'' - - John Wayne
SvoBrown is offline   Reply With Quote
Old 10-09-2010, 08:00 AM   #10
Wickd GT
Friends
 
Wickd GT's Avatar
 
Join Date: Dec 2004
Posts: 1,645
Quote:
Originally Posted by SvoBrown View Post
I had a lifter that exploded and caused something like that. Valve stayed open then stayed shut. Beat the hell out of the cam.

another time had an injector bank start going out on the puter. Caused the same thing.

It sounds like the timing is jumping up and down. You might see something with the light on the dyno at cruise speed.

Can you drive it with the spout out, Timing locked and see if that is it. Go low to be safe.
I have done everything imaginable I can think of. So, there is friend of mine here that has a shop, which the Ford dealers from around here go to him because they can't do something they can't do and has tools and software they don't have to diagnose. So I took it to him and has check wiring harness, Injectors, timing etc... All has passed. Then he drove it and he call me back. He told me that he is certain this is a very lean condition at cruise, how is 17:1- 19:1 A/F ratio between 1200-2000rpm! He even said to me it was scary to see that AFR. He is waiting on some other diagnostic software that he order and then he is going to check Monday the computer, he is going to take it apart and then read whats in the computer. He has the Quarter horse tuning stuff and is going to test the car live with the laptop and have the computer Live with the person who sells this product and see what is going on. Then if he fixes this problem then I'm going to buy a Bullet proof AOD from http://www.silverfoxtrans.com

Check that site. This guy is the one that did the tranny for the guy in Orlando that travell in his twin turbo to Commerce for the NMRA. He did the true street came runner up with 8.8x average, load up his stuff and drove back to Orlando thats 1,000 miles round trip and the tranny survive. Lets see, if he can't find it, which he is an ex technician from Ford when he worked in the Ford factory at Detroit or Michigan, then this thing is either going to be sold or I'm going to part it out completely to the ground.

Edgar
Wickd GT is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:53 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.