StreetStangs.net  

Go Back   StreetStangs.net > Technical > Ford Pushrod Tech (5.0 & 5.8)

Reply
 
Thread Tools Display Modes
Old 06-14-2008, 09:51 AM   #1
militarymustang88gt
Senior Member
 
militarymustang88gt's Avatar
 
Join Date: Jun 2007
Location: bham and auburn
Posts: 337
cant get oil leak fixed.

dont know what the hell is going on. but i have oil coming out from under my drivers side valve cover. tried three gaskets and finally just put gasket maker on the last gasket and it is still leaking. i have ball peened the bolt holes on them so that they would grab and pull down more from where the bolts were tightened before and this is just mind blowing. i am 100% positive it isnt the lower intake. but i am just worried that it might catch on fire because it is dripping on the collector and i would have more time to mess with it if it were in auburn.
__________________
finally got my avatar. it is the white one.
militarymustang88gt is offline   Reply With Quote
Old 06-14-2008, 01:29 PM   #2
coupe
Super Moderator
 
coupe's Avatar
 
Join Date: Dec 2004
Posts: 6,312
Warped valve cover maybe? Are you using the cork gaskets? Get the metal-insert silicone one. FELPRO has a blue one and Ford has a black one. My guess is somehow the valve cover and the rail it sits on are not seating well enough to let a gasket do it's job.
__________________
" If you can't explain it simply, you don't understand it well enough. " - Albert Einstein
coupe is offline   Reply With Quote
Old 06-14-2008, 01:45 PM   #3
EHardy1971
Trunk Monkey
 
EHardy1971's Avatar
 
Join Date: Jun 2007
Location: Home
Posts: 5,702
Try cleaning out the valve cover bolt holes in the head,they might have some gunk down in them that's keeping the bolts from going in far enough.
__________________
Eric
89 LX Coupe-Juiced
01 Lightning-Boost
06 TBSS
EHardy1971 is offline   Reply With Quote
Old 06-14-2008, 04:57 PM   #4
SkurdalenFox
Senior Member
 
SkurdalenFox's Avatar
 
Join Date: Sep 2005
Location: Boulder, CO
Posts: 463
I agree w/ Matt and Ehardy. Also make sure you're not over tightening the bolts.
__________________
Jim
SkurdalenFox is offline   Reply With Quote
Old 06-14-2008, 05:08 PM   #5
militarymustang88gt
Senior Member
 
militarymustang88gt's Avatar
 
Join Date: Jun 2007
Location: bham and auburn
Posts: 337
i am using a torque wrench to tighten the valve cover bolts to 12 lb ft. i tried cork first then went with the rubber felpro ones that have the notches that hold it to the valve cover. then went and got thicker ones. and the thick ones after they started to leak i took them off wiped them down and put silicone on both sides and stuck them back on. let it dry overnight and still no luck. i am just gettin sick of all the little stuff. i am picky and oil leak is my number one hated thing.
__________________
finally got my avatar. it is the white one.
militarymustang88gt is offline   Reply With Quote
Old 06-14-2008, 08:00 PM   #6
Craig K.
Nothing new here
 
Craig K.'s Avatar
 
Join Date: Dec 2004
Location: Senoia, GA
Posts: 2,971
try new valve covers, the Ford aluminum ones are nice look great and cost little.

I would try as coupe said to get the silicone ones with the metal ring in them, i have a set and have not had a valve cover leak in years
__________________
1985 Monte Carlo SS
2005 BMW 330I ZHP
Craig K. is offline   Reply With Quote
Old 06-14-2008, 08:07 PM   #7
militarymustang88gt
Senior Member
 
militarymustang88gt's Avatar
 
Join Date: Jun 2007
Location: bham and auburn
Posts: 337
i have ford racing ones. looked harder tonight and it isnt my valve cover or my lower intake. now i have no clue what it is. i think my buddy put too much oil in and it is running out of the dip stick tube. when i was saying earlier i had not checked the valve covers again and just saw a little puddle on the ground. but checked it isnt leaking now and i think it is just running out the dipstick hole on the oil pan since the dipstick is loose anyways.
__________________
finally got my avatar. it is the white one.
militarymustang88gt is offline   Reply With Quote
Old 06-18-2008, 12:19 PM   #8
EHardy1971
Trunk Monkey
 
EHardy1971's Avatar
 
Join Date: Jun 2007
Location: Home
Posts: 5,702
Quote:
Originally Posted by militarymustang88gt View Post
i think my buddy put too much oil in and it is running out of the dip stick tube.
Did he mistake quarts for gallons?
__________________
Eric
89 LX Coupe-Juiced
01 Lightning-Boost
06 TBSS
EHardy1971 is offline   Reply With Quote
Old 06-20-2008, 08:58 PM   #9
militarymustang88gt
Senior Member
 
militarymustang88gt's Avatar
 
Join Date: Jun 2007
Location: bham and auburn
Posts: 337
no we put two quarts over like two weeks on the lifter vally to keep them from rusting and forgot. it is all fixed now but thanks guys.
__________________
finally got my avatar. it is the white one.
militarymustang88gt is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:03 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.